安装scrapy error: Microsoft Visual C++ 14.0 is required

版权声明:本文为博主原创文章,转载请注明出处:http://blog.csdn.net/nima1994

问题描述

当前环境win7,python_3.6.1,32位。 在windows下,在dos中运行pip install Scrapy报错:

解决方案

http://www.lfd.uci.edu/~gohlke/pythonlibs/#twisted 下载twisted对应版本的whl文件(如我的Twisted‑18.9.0‑cp37‑cp37m‑win_amd64.whl),cp后面是python版本,amd64代表64位,运行命令: 其中install后面为下载的whl文件的完整路径名 安装完成后,再次运行: 即可成功。

未经允许不得转载:MR LYU » 安装scrapy error: Microsoft Visual C++ 14.0 is required

赞 (0)

评论 0

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址